What’s Vulnerable › Vulnerabilities
CVE-2024-9242: Memberful – Membership Plugin <= 1.73.7 - Authenticated (contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Memberful – Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'memberful_buy_subscription_link' and 'memberful_podcasts_link' shortcodes in all versions up to, and including, 1.73.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Memberful – Membership Plugin: before 1.73.8 — fixed in 1.73.8
How to fix
Upgrade to a fixed version: Memberful – Membership Plugin 1.73.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/memberful-wp/tags/1.73.7/src/shortcodes.php#L25
- https://plugins.trac.wordpress.org/browser/memberful-wp/tags/1.73.7/src/shortcodes.php#L59
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3161020%40memberful-wp&new=3161020%40memberful-wp&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e9e30377-2b5a-4b2d-9f19-bae91608fb24?source=cve
Get alerted when CVE-2024-9242 or the next vulnerability affects your stack