What’s Vulnerable › Vulnerabilities
CVE-2024-9257: Logsign Unified SecOps Platform delete_gsuite_key_file Input Validation Arbitrary File Deletion Vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-22 · updated 2026-06-17
- Weakness: CWE-20
Description
Logsign Unified SecOps Platform delete_gsuite_key_file Input Validation Arbitrary File Deletion Vulnerability. This vulnerability allows remote attackers to delete arbitrary files within sensitive directories on affected installations of Logsign Unified SecOps Platform. Authentication is required to exploit this vulnerability. The specific flaw exists within the delete_gsuite_key_file endpoint. The issue results from the lack of proper validation of a user-supplied filename prior to using it in file operations. An attacker can leverage this vulnerability to delete critical files on the system. Was ZDI-CAN-25265.
Affected products
- Logsign Unified SecOps Platform: before 6.4.26 — fixed in 6.4.26
How to fix
Upgrade to a fixed version: Logsign Unified SecOps Platform 6.4.26. Check the vendor advisory for mitigations.
References
- https://support.logsign.net/hc/en-us/articles/21062889743762-30-08-2024-Version-6-4-26-Release-Notes
- https://www.zerodayinitiative.com/advisories/ZDI-24-1295/
Get alerted when CVE-2024-9257 or the next vulnerability affects your stack