What’s Vulnerable › Vulnerabilities
CVE-2024-9265: Echo RSS Feed Post Generator <= 5.4.6 - Unauthenticated Privilege Escalation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-01 · updated 2026-06-17
- Weakness: CWE-269
Description
The Echo RSS Feed Post Generator plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 5.4.6. This is due to the plugin not properly restricting the roles that can set during registration through the echo_check_post_header_sent() function. This makes it possible for unauthenticated attackers to register as an administrator.
Affected products
- CodeRevolution Echo RSS Feed Post Generator: before 5.4.7 — fixed in 5.4.7
How to fix
Upgrade to a fixed version: CodeRevolution Echo RSS Feed Post Generator 5.4.7. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/echo-rss-feed-post-generator-plugin-for-wordpress/19486974
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c099f401-4b05-4532-8e31-af1b1dea7eca?source=cve
Get alerted when CVE-2024-9265 or the next vulnerability affects your stack