What’s Vulnerable › Vulnerabilities
CVE-2024-9289: WordPress & WooCommerce Affiliate Program <= 8.4.1 - Authentication Bypass to Account Takeover and Privilege Escalation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-01 · updated 2026-06-17
- Weakness: CWE-288
Description
The WordPress & WooCommerce Affiliate Program plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 8.4.1. This is due to the rtwwwap_login_request_callback() function not properly validating a user's identity prior to authenticating them to the site. This makes it possible for unauthenticated attackers to log in as any user, including administrators, granted they have access to the administrator's email.
Affected products
- RedefiningTheWeb WordPress & WooCommerce Affiliate Program: before 8.5.0 — fixed in 8.5.0
How to fix
Upgrade to a fixed version: RedefiningTheWeb WordPress & WooCommerce Affiliate Program 8.5.0. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/wordpress-woocommerce-affiliate-program/23580333
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ed19835f-2718-41d8-95af-47c8b9589529?source=cve
Get alerted when CVE-2024-9289 or the next vulnerability affects your stack