What’s Vulnerable › Vulnerabilities
CVE-2024-9312
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-10 · updated 2026-06-17
- Weakness: CWE-286
Description
Authd, through version 0.3.6, did not sufficiently randomize user IDs to prevent collisions. A local attacker who can register user names could spoof another user's ID and gain their privileges.
Affected products
- Canonical authd: before 0.3.6 — fixed in 0.3.6
How to fix
Upgrade to a fixed version: Canonical authd 0.3.6. Check the vendor advisory for mitigations.
References
- https://github.com/ubuntu/authd/security/advisories/GHSA-4gfw-wf7c-w6g2
- https://www.cve.org/CVERecord?id=CVE-2024-9312
Get alerted when CVE-2024-9312 or the next vulnerability affects your stack