What’s Vulnerable › Vulnerabilities
CVE-2024-9351: Forminator Forms – Contact Form, Payment Form & Custom Form Builder <= 1.35.1 - Cross-Site Request Forgery to Draft Quiz Creation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-17 · updated 2026-06-17
- Weakness: CWE-352
Description
The Forminator Forms – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.35.1. This is due to missing or incorrect nonce validation on the quiz 'create_module' function. This makes it possible for unauthenticated attackers to create draft quizzes via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- wpmudev Forminator Forms – Contact Form, Payment Form & Custom Form Builder: before 1.36.0 — fixed in 1.36.0
How to fix
Upgrade to a fixed version: wpmudev Forminator Forms – Contact Form, Payment Form & Custom Form Builder 1.36.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/forminator/tags/1.35.0/library/modules/quizzes/admin/admin-loader.php#L719
- https://plugins.trac.wordpress.org/changeset/3169243/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8d89e3b7-d980-42bb-ab0c-d86ab174a69c?source=cve
Get alerted when CVE-2024-9351 or the next vulnerability affects your stack