What’s Vulnerable › Vulnerabilities
CVE-2024-9356: Yotpo: Product & Photo Reviews for WooCommerce <= 1.7.9 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Yotpo: Product & Photo Reviews for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'yotpo_user_email' and 'yotpo_user_name' parameters in all versions up to, and including, 1.7.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- Yotpo: Product & Photo Reviews for WooCommerce: before 1.7.10 — fixed in 1.7.10
How to fix
Upgrade to a fixed version: Yotpo: Product & Photo Reviews for WooCommerce 1.7.10. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/yotpo-social-reviews-for-woocommerce/trunk/lib/utils/wc-yotpo-settings-functions.php#L100
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3188756%40yotpo-social-reviews-for-woocommerce&new=3188756%40yotpo-social-reviews-for-woocommerce&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2f7ddb34-cb5b-4089-bd3e-07056f0b6bd5?source=cve
Get alerted when CVE-2024-9356 or the next vulnerability affects your stack