What’s Vulnerable › Vulnerabilities
CVE-2024-9388: Black Widgets For Elementor <= 1.3.7 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Black Widgets For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.3.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
Affected products
- Modernaweb Studio Black Widgets For Elementor: before 1.3.8 — fixed in 1.3.8
How to fix
Upgrade to a fixed version: Modernaweb Studio Black Widgets For Elementor 1.3.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/black-widgets/trunk/includes/class-bw.php#L95
- https://plugins.trac.wordpress.org/changeset/3178366/
- https://wordpress.org/plugins/black-widgets/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/618c72b1-363b-41ad-939d-ab2a3b4d579c?source=cve
Get alerted when CVE-2024-9388 or the next vulnerability affects your stack