What’s Vulnerable › Vulnerabilities
CVE-2024-9396
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-01 · updated 2026-06-17
- Weakness: CWE-119
Description
It is currently unknown if this issue is exploitable but a condition may arise where the structured clone of certain objects could lead to memory corruption. This vulnerability affects Firefox < 131, Firefox ESR < 128.3, Thunderbird < 128.3, and Thunderbird < 131.
Affected products
- Mozilla Firefox: before 128.3.0; before 131.0 — fixed in 128.3.0, 131.0
- Mozilla Thunderbird: before 128.3.0; from 129.0 before 131.0 — fixed in 128.3.0, 131.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 128.3.0, 131.0; Mozilla Thunderbird 128.3.0, 131.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1912471
- https://www.mozilla.org/security/advisories/mfsa2024-46/
- https://www.mozilla.org/security/advisories/mfsa2024-47/
- https://www.mozilla.org/security/advisories/mfsa2024-49/
- https://www.mozilla.org/security/advisories/mfsa2024-50/
Get alerted when CVE-2024-9396 or the next vulnerability affects your stack