What’s Vulnerable › Vulnerabilities
CVE-2024-9400
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-01 · updated 2026-06-17
- Weakness: CWE-119
Description
A potential memory corruption vulnerability could be triggered if an attacker had the ability to trigger an OOM at a specific moment during JIT compilation. This vulnerability affects Firefox < 131, Firefox ESR < 128.3, Thunderbird < 128.3, and Thunderbird < 131.
Affected products
- Mozilla Firefox: before 128.3.0; before 131.0 — fixed in 128.3.0, 131.0
- Mozilla Thunderbird: before 128.3.0; from 129.0 before 131.0 — fixed in 128.3.0, 131.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 128.3.0, 131.0; Mozilla Thunderbird 128.3.0, 131.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1915249
- https://www.mozilla.org/security/advisories/mfsa2024-46/
- https://www.mozilla.org/security/advisories/mfsa2024-47/
- https://www.mozilla.org/security/advisories/mfsa2024-49/
- https://www.mozilla.org/security/advisories/mfsa2024-50/
Get alerted when CVE-2024-9400 or the next vulnerability affects your stack