What’s Vulnerable › Vulnerabilities
CVE-2024-9413
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-13 · updated 2026-06-17
- Weakness: CWE-755
Description
The transport_message_handler function in SCP-Firmware release versions 2.11.0-2.15.0 does not properly handle errors, potentially allowing an Application Processor (AP) to cause a buffer overflow in System Control Processor (SCP) firmware.
Affected products
- Arm SCP-Firmware: from 2.11.0 before 2.16.0 — fixed in 2.16.0
How to fix
Upgrade to a fixed version: Arm SCP-Firmware 2.16.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9413 or the next vulnerability affects your stack