What’s Vulnerable › Vulnerabilities
CVE-2024-9416: Modula Image Gallery <= 2.10.1 - Authenticated (Contributor+) Stored DOM-Based Cross-Site Scripting via FancyBox 5 JavaScript Library
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The Modula Image Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's bundled FancyBox JavaScript library (versions <= 5.0.36) due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wpchill Modula Image Gallery – Photo Grid & Video Gallery: before 2.10.2 — fixed in 2.10.2
How to fix
Upgrade to a fixed version: wpchill Modula Image Gallery – Photo Grid & Video Gallery 2.10.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3160235/modula-best-grid-gallery
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1954040c-2188-48b7-9f21-9a0c851c9165?source=cve
Get alerted when CVE-2024-9416 or the next vulnerability affects your stack