What’s Vulnerable › Vulnerabilities
CVE-2024-9420
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-12 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free in Ivanti Connect Secure before version 22.7R2.3 and 9.1R18.9 and Ivanti Policy Secure before version 22.7R1.2 allows a remote authenticated attacker to achieve remote code execution
Affected products
- Ivanti Connect Secure (Pulse Secure): before 9.1; from 21.9 before 22.7; 9.1, 9.1-r1, 9.1-r1.0, 9.1-r10, 9.1-r10.0, 9.1-r10.2 (+60) — fixed in 22.7, 9.1
- Ivanti Policy Secure: before 22.7; 22.7, 22.7-r1, 22.7-r1.1 — fixed in 22.7
How to fix
Upgrade to a fixed version: Ivanti Connect Secure (Pulse Secure) 22.7, 9.1; Ivanti Policy Secure 22.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9420 or the next vulnerability affects your stack