What’s Vulnerable › Vulnerabilities
CVE-2024-9422: GEO My WordPress < 4.5 - Admin+ Arbitrary File Upload
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-22 · updated 2026-06-17
Description
The GEO my WP WordPress plugin before 4.5, gmw-premium-settings WordPress plugin before 3.1 does not sufficiently validate files to be uploaded, which could allow attackers to upload arbitrary files such as PHP on the server.
Affected products
- Eyal Fitoussi GEO my WordPress: before 4.5 — fixed in 4.5
- Geomywp Geo My Wordpress Premium Settings: before 3.1 — fixed in 3.1
How to fix
Upgrade to a fixed version: Eyal Fitoussi GEO my WordPress 4.5; Geomywp Geo My Wordpress Premium Settings 3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9422 or the next vulnerability affects your stack