What’s Vulnerable › Vulnerabilities
CVE-2024-9428: Popup Builder < 4.3.5 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Popup Builder WordPress plugin before 4.3.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Popup Builder: before 4.3.5 — fixed in 4.3.5
How to fix
Upgrade to a fixed version: Popup Builder 4.3.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6e246547-e509-48db-88ae-b2f943398377/
- https://wpscan.com/vulnerability/6e246547-e509-48db-88ae-b2f943398377/
Get alerted when CVE-2024-9428 or the next vulnerability affects your stack