What’s Vulnerable › Vulnerabilities

CVE-2024-9440: Slim Select 2.0 createOption "text" XSS

Description

Slim Select 2.0 versions through 2.9.0 are affected by a potential cross-site scripting vulnerability. In select.ts:createOption(), the text variable from the user-provided Options object is assigned to an innerHTML without sanitation. Software that depends on this library to dynamically generate lists using unsanitized user-provided input may be vulnerable to cross-site scripting, resulting in attacker executed JavaScript. At this time, no patch is available.

Affected products

How to fix

Upgrade to a fixed version: Slimselectjs Slim Select 2.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-9440 or the next vulnerability affects your stack