What’s Vulnerable › Vulnerabilities
CVE-2024-9443: Basticom Framework <= 1.5.0 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Basticom Framework plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.5.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
Affected products
- Basticom Framework: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: Basticom Framework 1.5.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3178823/
- https://wordpress.org/plugins/basticom-framework/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3dd3dc4b-e936-46a4-8d65-5f4bf05b2374?source=cve
Get alerted when CVE-2024-9443 or the next vulnerability affects your stack