What’s Vulnerable › Vulnerabilities
CVE-2024-9461: Total Upkeep <= 1.16.6 - Authenticated (Administrator+) Remote Code Execution via Backup Settings
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-78
Description
The Total Upkeep – WordPress Backup Plugin plus Restore & Migrate by BoldGrid plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.16.6 via the cron_interval parameter. This is due to missing input validation and sanitization. This makes it possible for authenticated attackers, with Administrator-level access and above, to execute code on the server.
Affected products
- boldgrid Total Upkeep – WordPress Backup Plugin plus Restore & Migrate by BoldGrid: before 1.16.7 — fixed in 1.16.7
How to fix
Upgrade to a fixed version: boldgrid Total Upkeep – WordPress Backup Plugin plus Restore & Migrate by BoldGrid 1.16.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/boldgrid-backup/tags/1.16.5/admin/class-boldgrid-backup-admin-settings.php#L748
- https://www.wordfence.com/threat-intel/vulnerabilities/id/804b42a0-1cea-4f68-bd4a-d292a9f23fbe?source=cve
Get alerted when CVE-2024-9461 or the next vulnerability affects your stack