What’s Vulnerable › Vulnerabilities
CVE-2024-9487: An Improper Verification of Cryptographic Signature vulnerability was identified in GitHub Enterprise Server that allowed SAML SSO authentication to be bypassed when the encrypted assertions feature was enabled
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 25.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-10 · updated 2026-06-17
- Weakness: CWE-347
Description
An improper verification of cryptographic signature vulnerability was identified in GitHub Enterprise Server that allowed SAML SSO authentication to be bypassed resulting in unauthorized provisioning of users and access to the instance. Exploitation required the encrypted assertions feature to be enabled, and the attacker would require direct network access as well as a signed SAML response or metadata document. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.15 and was fixed in versions 3.11.16, 3.12.10, 3.13.5, and 3.14.2. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: before 3.11.16; from 3.12.0 before 3.12.10; from 3.13.0 before 3.13.5; from 3.14.0 before 3.14.2 — fixed in 3.11.16, 3.12.10, 3.13.5, 3.14.2
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.11.16, 3.12.10, 3.13.5, 3.14.2. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.16
- https://docs.github.com/en/enterprise-server@3.12/admin/release-notes#3.12.10
- https://docs.github.com/en/enterprise-server@3.13/admin/release-notes#3.13.5
- https://docs.github.com/en/enterprise-server@3.14/admin/release-notes#3.14.2
Get alerted when CVE-2024-9487 or the next vulnerability affects your stack