What’s Vulnerable › Vulnerabilities
CVE-2024-9488: Comments – wpDiscuz <= 7.6.24 - Authentication Bypass via WordPress.com OAuth provider
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-25 · updated 2026-06-17
- Weakness: CWE-288
Description
The Comments – wpDiscuz plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 7.6.24. This is due to insufficient verification on the user being returned by the social login token. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the email and the user does not have an already-existing account for the service returning the token.
Affected products
- gVectors wpDiscuz: before 7.6.25 — fixed in 7.6.25
How to fix
Upgrade to a fixed version: gVectors wpDiscuz 7.6.25. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wpdiscuz/trunk/forms/wpdFormAttr/Login/SocialLogin.php
- https://plugins.trac.wordpress.org/changeset/3164486/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b71706a7-e101-4d50-a2da-1aeeaf07cf4b?source=cve
Get alerted when CVE-2024-9488 or the next vulnerability affects your stack