What’s Vulnerable › Vulnerabilities
CVE-2024-9528: Contact Form Plugin by Fluent Forms for Quiz, Survey, and Drag & Drop WP Form Builder <= 5.1.19 - Authenticated (Form Manager+) Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Contact Form Plugin by Fluent Forms for Quiz, Survey, and Drag & Drop WP Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via form label fields in all versions up to, and including, 5.1.19 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with access to edit forms (administrator by default), to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- techjewel Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder: before 5.1.20 — fixed in 5.1.20
How to fix
Upgrade to a fixed version: techjewel Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder 5.1.20. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/fluentform/tags/5.1.17/app/Services/FormBuilder/Components/BaseComponent.php#L191
- https://plugins.trac.wordpress.org/browser/fluentform/tags/5.1.17/boot/globals.php#L342
- https://plugins.trac.wordpress.org/changeset/3125227/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4ed4dfee-5f14-47ce-abed-cd226c110665?source=cve
Get alerted when CVE-2024-9528 or the next vulnerability affects your stack