What’s Vulnerable › Vulnerabilities
CVE-2024-9530: Qi Addons For Elementor <= 1.8.0 - Sensitive Information Exposure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-23 · updated 2026-06-17
- Weakness: CWE-200
Description
The Qi Addons For Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.8.0 via private templates. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive data including the contents of templates that are private.
Affected products
- qodeinteractive Qi Addons For Elementor: before 1.8.1 — fixed in 1.8.1
How to fix
Upgrade to a fixed version: qodeinteractive Qi Addons For Elementor 1.8.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3170536%40qi-addons-for-elementor%2Ftrunk&old=3159768%40qi-addons-for-elementor%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0dd93514-657c-4b04-931a-23f3d405fb88?source=cve
Get alerted when CVE-2024-9530 or the next vulnerability affects your stack