What’s Vulnerable › Vulnerabilities
CVE-2024-9541: News Kit Elementor Addons <= 1.2.1 - Authenticated (Contributor+) Sensitive Information Exposure via Canvas Menu Elementor Template
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-22 · updated 2026-06-17
- Weakness: CWE-200
Description
The News Kit Elementor Addons plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.2.1 via the render function in includes/widgets/canvas-menu/canvas-menu.php. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive private, pending, and draft Elementor template data.
Affected products
- blazethemes News Kit Elementor Addons: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: blazethemes News Kit Elementor Addons 1.2.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3169975/news-kit-elementor-addons
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ffc5408c-ca31-4cb6-8cb5-063acbbad01e?source=cve
Get alerted when CVE-2024-9541 or the next vulnerability affects your stack