What’s Vulnerable › Vulnerabilities
CVE-2024-9546: WPIDE <= 3.4.9 - Unauthenticated Full Path Dislcosure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-15 · updated 2026-06-17
- Weakness: CWE-200
Description
The WPIDE – File Manager & Code Editor plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 3.4.9. This is due to the plugin utilizing the PHP-Parser library, which outputs parser rebuild command execution results. This makes it possible for unauthenticated attackers to retrieve the full path of the web application, which can be used to aid other attacks. The information displayed is not useful on its own, and requires another vulnerability to be present for damage to an affected website.
Affected products
- XplodedThemes WPIDE – File Manager & Code Editor: before 3.5.0 — fixed in 3.5.0
How to fix
Upgrade to a fixed version: XplodedThemes WPIDE – File Manager & Code Editor 3.5.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wpide/tags/3.4.9/vendor/nikic/php-parser/grammar/rebuildParsers.php#L77
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e884af8b-c83f-4380-bfaf-f1419fce125c?source=cve
Get alerted when CVE-2024-9546 or the next vulnerability affects your stack