What’s Vulnerable › Vulnerabilities
CVE-2024-9571: Cross-Site Scripting vulnerability in SOPlanning
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-Site Scripting (XSS) vulnerability in SOPlanning <1.45, due to lack of proper validation of user input via /soplanning/www/process/xajax_server.php, affecting multiple parameters. This could allow a remote user to send a specially crafted query to an authenticated user and partially take control of their browser session.
Affected products
- SOPlanning: before 1.45 — fixed in 1.45
How to fix
Upgrade to a fixed version: SOPlanning 1.45. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9571 or the next vulnerability affects your stack