What’s Vulnerable › Vulnerabilities
CVE-2024-9579: Certain Poly Video Conference Devices – Potential Remote Code Execution
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-05 · updated 2026-06-17
- Weakness: CWE-77
Description
A potential vulnerability was discovered in certain Poly video conferencing devices. The firmware flaw does not properly sanitize user input. The exploitation of this vulnerability is dependent on a layered attack and cannot be exploited by itself.
Affected products
- HP Poly Studio G62 Firmware: before 4.3.2 — fixed in 4.3.2
- HP Poly Studio G7500 Firmware: before 4.3.2 — fixed in 4.3.2
- HP Poly Studio X30 Firmware: through 4.3.2
- HP Poly Studio X50 Firmware: before 4.3.2 — fixed in 4.3.2
- HP Poly Studio X52 Firmware: before 4.3.2 — fixed in 4.3.2
- HP Poly Studio X70 Firmware: before 4.3.2 — fixed in 4.3.2
- HP Poly Tc10 Firmware: before 6.3.2 — fixed in 6.3.2
- HP Poly Tc8 Firmware: before 6.3.2 — fixed in 6.3.2
How to fix
Upgrade to a fixed version: HP Poly Studio G62 Firmware 4.3.2; HP Poly Studio G7500 Firmware 4.3.2; HP Poly Studio X50 Firmware 4.3.2; HP Poly Studio X52 Firmware 4.3.2; HP Poly Studio X70 Firmware 4.3.2; HP Poly Tc10 Firmware 6.3.2; HP Poly Tc8 Firmware 6.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9579 or the next vulnerability affects your stack