What’s Vulnerable › Vulnerabilities
CVE-2024-9582: Accordion Slider <= 1.9.11 - Authenticted (Contributor+) Stored Cross-Site Scripting via HTML Attribute
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Accordion Slider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘html’ attribute of an accordion slider in all versions up to, and including, 1.9.11 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: Successful exploitation by Contributor-level users requires an Administrator-level user to provide access to the plugin's admin area via the `Access` plugin setting, which is restricted to administrators by default.
Affected products
- bqworks Accordion Slider: before 1.9.12; 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.9.0 (+13) — fixed in 1.9.12
How to fix
Upgrade to a fixed version: bqworks Accordion Slider 1.9.12. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3166480/accordion-slider
- https://www.wordfence.com/threat-intel/vulnerabilities/id/94f19f56-0667-443e-8545-a17fbe9c3ddb?source=cve
Get alerted when CVE-2024-9582 or the next vulnerability affects your stack