What’s Vulnerable › Vulnerabilities
CVE-2024-9586: Linkz.ai <= 1.1.8 - Missing Authorization to Unauthenticated Plugin Settings Update
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-11 · updated 2026-06-17
- Weakness: CWE-862
Description
The Linkz.ai plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'check_auth' and 'check_logout' functions in versions up to, and including, 1.1.8. This makes it possible for unauthenticated attackers to update plugin settings.
Affected products
- vittor1o Linkz.ai – Automatic link previews on hover: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: vittor1o Linkz.ai – Automatic link previews on hover 1.2.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/linkz-ai/tags/1.1.8/init.php#L142
- https://plugins.trac.wordpress.org/browser/linkz-ai/tags/1.1.8/init.php#L159
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3168515%40linkz-ai&new=3168515%40linkz-ai&sfp_email=&sfph_mail=#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b4b4ca5b-c806-4b68-acb8-6b63d6ca5728?source=cve
Get alerted when CVE-2024-9586 or the next vulnerability affects your stack