What’s Vulnerable › Vulnerabilities
CVE-2024-9596: Inclusion of Sensitive Information in Source Code in GitLab
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-10 · updated 2026-06-17
- Weakness: CWE-540
Description
An issue has been discovered in GitLab EE affecting all versions starting from 16.6 prior to 17.2.9, from 17.3 prior to 17.3.5, and from 17.4 prior to 17.4.2. It was possible for an unauthenticated attacker to determine the GitLab version number for a GitLab instance.
Affected products
- GitLab: from 16.6.0 before 17.2.9; from 17.3.0 before 17.3.5; from 17.4.0 before 17.4.2 — fixed in 17.2.9, 17.3.5, 17.4.2
How to fix
Upgrade to a fixed version: GitLab 17.2.9, 17.3.5, 17.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9596 or the next vulnerability affects your stack