What’s Vulnerable › Vulnerabilities
CVE-2024-9598: AMP for WP – Accelerated Mobile Pages <= 1.0.99.1 - Cross-Site Request Forgery to Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-25 · updated 2026-06-17
- Weakness: CWE-352
Description
The AMP for WP – Accelerated Mobile Pages plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.99.1. This is due to missing or incorrect nonce validation on the 'proxy' function. This makes it possible for unauthenticated attackers to send the logged in user's cookies to their own server via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- mohammed_kaludi AMP for WP – Accelerated Mobile Pages: before 1.0.99.2 — fixed in 1.0.99.2
How to fix
Upgrade to a fixed version: mohammed_kaludi AMP for WP – Accelerated Mobile Pages 1.0.99.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/accelerated-mobile-pages/tags/1.0.98/includes/options/redux-core/inc/class.p.php#L16
- https://plugins.trac.wordpress.org/changeset/3174071/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6b155ec8-d69d-40cf-8bea-201629bc9ca6?source=cve
Get alerted when CVE-2024-9598 or the next vulnerability affects your stack