What’s Vulnerable › Vulnerabilities
CVE-2024-9600: Ditty < 3.1.47 - Author+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ditty WordPress plugin before 3.1.47 does not sanitise and escape some of its settings, which could allow high privilege users such as author to perform Stored Cross-Site Scripting attacks.
Affected products
- Ditty: before 3.1.47 — fixed in 3.1.47
How to fix
Upgrade to a fixed version: Ditty 3.1.47. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9600 or the next vulnerability affects your stack