What’s Vulnerable › Vulnerabilities

CVE-2024-9623: Incorrect Authorization in GitLab

Description

An issue was discovered in GitLab CE/EE affecting all versions starting from 8.16 prior to 17.2.9, starting from 17.3 prior to 17.3.5, and starting from 17.4 prior to 17.4.2, which allows deploy keys to push to an archived repository.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.2.9, 17.3.5, 17.4.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-9623 or the next vulnerability affects your stack