What’s Vulnerable › Vulnerabilities
CVE-2024-9637: School Management System – WPSchoolPress <= 2.2.10 - Insecure Direct Object Reference to Authenticated (Teacher+) Account Takeover/Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-26 · updated 2026-06-17
- Weakness: CWE-639
Description
The School Management System – WPSchoolPress plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 2.2.10. This is due to the plugin not properly validating a user's identity prior to updating their details like email. This makes it possible for authenticated attackers, with teacher-level access and above, to change arbitrary user's email addresses, including administrators, and leverage that to reset the user's password and gain access to their account.
Affected products
- jdsofttech School Management System – WPSchoolPress: before 2.2.11 — fixed in 2.2.11
How to fix
Upgrade to a fixed version: jdsofttech School Management System – WPSchoolPress 2.2.11. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wpschoolpress/tags/2.2.9/lib/wpsp-ajaxworks-teacher.php#L598
- https://plugins.trac.wordpress.org/changeset/3178510/wpschoolpress/trunk/lib/wpsp-ajaxworks-teacher.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/411693fc-9df3-44b1-9a6f-58a6e8ef23b8?source=cve
Get alerted when CVE-2024-9637 or the next vulnerability affects your stack