What’s Vulnerable › Vulnerabilities
CVE-2024-9638: Category Posts Widget < 4.9.18 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Category Posts Widget WordPress plugin before 4.9.18 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Category Posts Widget: before 4.9.18 — fixed in 4.9.18
How to fix
Upgrade to a fixed version: Category Posts Widget 4.9.18. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9638 or the next vulnerability affects your stack