What’s Vulnerable › Vulnerabilities
CVE-2024-9641: LuckyWP Table of Contents < 2.1.7 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The LuckyWP Table of Contents WordPress plugin before 2.1.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- theluckywp LuckyWP Table of Contents: before 2.1.7 — fixed in 2.1.7
How to fix
Upgrade to a fixed version: theluckywp LuckyWP Table of Contents 2.1.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/81aa922a-3b51-4cfe-9098-53234827610c/
- https://wpscan.com/vulnerability/81aa922a-3b51-4cfe-9098-53234827610c/
Get alerted when CVE-2024-9641 or the next vulnerability affects your stack