What’s Vulnerable › Vulnerabilities
CVE-2024-9645: Post Grid and Gutenberg Blocks < 2.2.93 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Post Grid, Posts Slider, Posts Carousel, Post Filter, Post Masonry WordPress plugin before 2.2.93 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- pickplugins Post Grid: before 2.2.93 — fixed in 2.2.93
How to fix
Upgrade to a fixed version: pickplugins Post Grid 2.2.93. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9645 or the next vulnerability affects your stack