What’s Vulnerable › Vulnerabilities
CVE-2024-9649: WP ULike <= 4.7.4 - Cross-Site Request Forgery to Statistic Deletion
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP ULike – The Ultimate Engagement Toolkit for Websites plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.7.4. This is due to missing or incorrect nonce validation on the wp_ulike_delete_history_api() function. This makes it possible for unauthenticated attackers to delete engagements via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- alimir WP ULike – Like & Dislike Buttons for Engagement and Feedback: before 4.7.5 — fixed in 4.7.5
How to fix
Upgrade to a fixed version: alimir WP ULike – Like & Dislike Buttons for Engagement and Feedback 4.7.5. Check the vendor advisory for mitigations.
References
- https://github.com/WordpressPluginDirectory/wp-ulike/blob/fd5eb54948cc1af9c348530a3cbd89c5a4bc68d0/wp-ulike/admin/admin-ajax.php#L78-L100
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3168233%40wp-ulike&new=3168233%40wp-ulike&sfp_email=&sfph_mail=#file0
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3fcb35f8-ed88-4440-8cdf-95c1f0028253?source=cve
Get alerted when CVE-2024-9649 or the next vulnerability affects your stack