What’s Vulnerable › Vulnerabilities
CVE-2024-9651: Contact Form Plugin by Fluent Forms < 5.2.1 - Admin+ Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Fluent Forms WordPress plugin before 5.2.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- techjewel Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder: before 5.2.1 — fixed in 5.2.1
How to fix
Upgrade to a fixed version: techjewel Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder 5.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9651 or the next vulnerability affects your stack