What’s Vulnerable › Vulnerabilities
CVE-2024-9664: WP All Import Pro <= 4.9.7 - Authenticated (Administrator+) PHP Object Injection via Import File
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-07 · updated 2026-06-17
- Weakness: CWE-502
Description
The WP All Import Pro plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 4.9.7 via deserialization of untrusted input from an import file. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Affected products
- Import any XML or CSV File to WordPress: before 4.9.8 — fixed in 4.9.8
How to fix
Upgrade to a fixed version: Import any XML or CSV File to WordPress 4.9.8. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0099a8d7-827d-4215-9a2b-b3c268fb5e97?source=cve
- https://www.wpallimport.com/
Get alerted when CVE-2024-9664 or the next vulnerability affects your stack