What’s Vulnerable › Vulnerabilities
CVE-2024-9667: Seriously Simple Podcasting <= 3.5.0 - Reflected Cross-Site Scripting via add_query_arg Parameter
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Seriously Simple Podcasting plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 3.5.0. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- Craig Hewitt Seriously Simple Podcasting: before 3.6.0 — fixed in 3.6.0
How to fix
Upgrade to a fixed version: Craig Hewitt Seriously Simple Podcasting 3.6.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/seriously-simple-podcasting/trunk/php/classes/handlers/class-options-handler.php#L101
- https://plugins.trac.wordpress.org/changeset/3181485/
- https://wordpress.org/plugins/seriously-simple-podcasting/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f4232656-2e97-4888-8dde-14039d8c2f9d?source=cve
Get alerted when CVE-2024-9667 or the next vulnerability affects your stack