What’s Vulnerable › Vulnerabilities
CVE-2024-9682: Royal Elementor Addons and Templates <= 1.7.1001 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting via Form Builder Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Royal Elementor Addons and Templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Form Builder widget in all versions up to, and including, 1.7.1001 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor: before 1.7.1002 — fixed in 1.7.1002
How to fix
Upgrade to a fixed version: wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor 1.7.1002. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/royal-elementor-addons/tags/1.7.1002/assets/js/frontend.js?rev=3184222#L8771
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bd90b85e-22a9-4c08-b2cf-4f75406e7ca3?source=cve
Get alerted when CVE-2024-9682 or the next vulnerability affects your stack