What’s Vulnerable › Vulnerabilities
CVE-2024-9687: WP 2FA with Telegram <= 3.0 - Authenticated (Subscriber+) Authentication Bypass
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-15 · updated 2026-06-17
- Weakness: CWE-639
Description
The WP 2FA with Telegram plugin for WordPress is vulnerable to Authentication Bypass in versions up to, and including, 3.0. This is due to insufficient validation of the user-controlled key on the 'validate_tg' action. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to log in as any existing user on the site, such as an administrator.
Affected products
- dueclic Wp 2Fa With Telegram: before 3.1 — fixed in 3.1
How to fix
Upgrade to a fixed version: dueclic Wp 2Fa With Telegram 3.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/two-factor-login-telegram/tags/3.0/includes/class-wp-factor-telegram-plugin.php#L244
- https://www.wordfence.com/threat-intel/vulnerabilities/id/13b5292f-4484-498b-b6b7-2895871ab794?source=cve
Get alerted when CVE-2024-9687 or the next vulnerability affects your stack