What’s Vulnerable › Vulnerabilities
CVE-2024-9693: Incorrect Authorization in GitLab
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-14 · updated 2026-06-17
- Weakness: CWE-863
Description
An issue was discovered in GitLab CE/EE affecting all versions starting from 16.0 prior to 17.3.7, starting from 17.4 prior to 17.4.4, and starting from 17.5 prior to 17.5.2, which could have allowed unauthorized access to the Kubernetes agent in a cluster under specific configurations.
Affected products
- GitLab: from 16.0.0 before 17.3.7; from 17.4.0 before 17.4.4; from 17.5.0 before 17.5.2 — fixed in 17.3.7, 17.4.4, 17.5.2
How to fix
Upgrade to a fixed version: GitLab 17.3.7, 17.4.4, 17.5.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9693 or the next vulnerability affects your stack