What’s Vulnerable › Vulnerabilities
CVE-2024-9699: Cross-Site Scripting (XSS) in flatpressblog/flatpress
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the file upload functionality of the FlatPress CMS admin panel (version latest) allows an attacker to upload a file with a JavaScript payload disguised as a filename. This can lead to a Cross-Site Scripting (XSS) attack if the uploaded file is accessed by other users. The issue is fixed in version 1.4.dev.
Affected products
- flatpressblog/flatpress: before 1.4 — fixed in 1.4
How to fix
Upgrade to a fixed version: flatpressblog/flatpress 1.4. Check the vendor advisory for mitigations.
References
- https://github.com/flatpressblog/flatpress/commit/f364391085334a7eae02aa2320edd6de7466ec85
- https://huntr.com/bounties/a993a05f-be50-4983-a44a-3bbff1ec00db
Get alerted when CVE-2024-9699 or the next vulnerability affects your stack