What’s Vulnerable › Vulnerabilities
CVE-2024-9704: Social Sharing (by Danny) <= 1.3.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Social Sharing (by Danny) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'dvk_social_sharing' shortcode in all versions up to, and including, 1.3.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- dvankooten Social Sharing (by Danny): before 1.3.8 — fixed in 1.3.8
How to fix
Upgrade to a fixed version: dvankooten Social Sharing (by Danny) 1.3.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3167056%40dvk-social-sharing&new=3167056%40dvk-social-sharing&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/619ca4b6-95bb-4c87-b8db-78e6d6b79384?source=cve
Get alerted when CVE-2024-9704 or the next vulnerability affects your stack