What’s Vulnerable › Vulnerabilities
CVE-2024-9769: Video Gallery <= 2.4.1 - Authenticated (Administrator+) Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Video Gallery – Best WordPress YouTube Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 2.4.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- totalsoft Video Gallery – YouTube Gallery, Vimeo, Video Portfolio, Image Portfolio and Image Gallery: before 2.4.2 — fixed in 2.4.2
How to fix
Upgrade to a fixed version: totalsoft Video Gallery – YouTube Gallery, Vimeo, Video Portfolio, Image Portfolio and Image Gallery 2.4.2. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/179304/WordPress-Gallery-2.3.6-Cross-Site-Scripting.html
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b57c9e58-64a6-48e8-8ef6-25608e4131e6?source=cve
Get alerted when CVE-2024-9769 or the next vulnerability affects your stack