What’s Vulnerable › Vulnerabilities
CVE-2024-9771: WP-Recall < 16.26.12 - Admin+ Stored XSS
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP-Recall WordPress plugin before 16.26.12 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- wppost WP-Recall – Registration, Profile, Commerce & More: before 16.26.12 — fixed in 16.26.12
How to fix
Upgrade to a fixed version: wppost WP-Recall – Registration, Profile, Commerce & More 16.26.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9771 or the next vulnerability affects your stack