What’s Vulnerable › Vulnerabilities
CVE-2024-9773: Improper Neutralization of Special Elements used in a Command ('Command Injection') in GitLab
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-77
Description
An issue was discovered in GitLab EE affecting all versions starting from 14.9 before 17.8.6, all versions starting from 17.9 before 17.8.3, all versions starting from 17.10 before 17.10.1. An input validation issue in the Harbor registry integration could have allowed a maintainer to add malicious code to the CLI commands shown in the UI.
Affected products
- GitLab: from 14.9.0 before 17.8.6; from 17.9.0 before 17.9.3; 17.10.0 — fixed in 17.8.6, 17.9.3
How to fix
Upgrade to a fixed version: GitLab 17.8.6, 17.9.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9773 or the next vulnerability affects your stack