What’s Vulnerable › Vulnerabilities
CVE-2024-9776: ImagePress - Image Gallery <= 1.2.2 - Authenticated (Administrator+) Stored Cross-Site Scripting via Plugin Settings
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The ImagePress – Image Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.2.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- butterflymedia ImagePress – Image Gallery: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: butterflymedia ImagePress – Image Gallery 1.3.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/image-gallery/trunk/includes/page-settings.php
- https://plugins.trac.wordpress.org/changeset/3167164/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/655c08e6-4ef2-438e-b381-1bc3748c3771?source=cve
Get alerted when CVE-2024-9776 or the next vulnerability affects your stack