What’s Vulnerable › Vulnerabilities
CVE-2024-9778: ImagePress – Image Gallery <= 1.2.2 - Cross-Site Request Forgery to Plugin Settings Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The ImagePress – Image Gallery plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.2.2. This is due to missing or incorrect nonce validation on the 'imagepress_admin_page' function. This makes it possible for unauthenticated attackers to update plugin settings, including redirection URLs, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- butterflymedia ImagePress – Image Gallery: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: butterflymedia ImagePress – Image Gallery 1.3.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/image-gallery/trunk/includes/page-settings.php#L106
- https://plugins.trac.wordpress.org/browser/image-gallery/trunk/includes/page-settings.php#L2
- https://plugins.trac.wordpress.org/browser/image-gallery/trunk/includes/page-settings.php#L267
- https://plugins.trac.wordpress.org/browser/image-gallery/trunk/includes/page-settings.php#L380
- https://plugins.trac.wordpress.org/browser/image-gallery/trunk/includes/page-settings.php#L461
- https://plugins.trac.wordpress.org/changeset/3167164/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/200b3446-6107-434b-b46d-2078461f3f94?source=cve
Get alerted when CVE-2024-9778 or the next vulnerability affects your stack